Número mayor y su posición

03/Mar/2009 Java , , , , 17 Comentarios
Programación en Java

Este es un problema básico a la hora de trabajar con arrays en Java. La idea es buscar el número más grande del array y la posición que ocupa.

Lo primero es declarar el array de números e inicializarlo con una secuencia cualquiera:

int[] listaNumeros = {1,4,7,8,9,2,7,15,4,6,9,8};

Lo siguiente, declarar dos variables, en las que almacenaremos el número mayor y su posición.

Para empezar asumiremos que el número mayor es el primero y que consecuentemente su posición es la cero (recuerda que los arrays empiezan por la posición 0).

Ahora, recorreremos todo el array. Para ello nos valemos de una estructura repetitiva tipo for y de la propiedad .length del array, la cual nos da el número de elementos que almacena el array.

for (int x=1;x<listaNumeros.length;x++){...}

Por cada elemento del array que recorramos deberemos de preguntar si dicho elemento es mayor que el que tenemos almacenado. Si esto se cumple pondremos este como nuevo número mayor y la variable de iteración del bucle como posición.

if (listaNumeros[x]>iNumeroMayor) {
  iNumeroMayor = listaNumeros[x];
  iPosicion = x;
}

Solo nos quedará mostrar los valores de iNumeroMayor e iPosicion. Simple, sencillo y en pocas líneas.

Vídeos sobre Java


17 comentarios en “Número mayor y su posición”

Víctor Cuervo

jose

Tiene un error logico este codigo

Víctor Cuervo

Víctor Cuervo

Jose,

A qué te refieres con error lógico?

Saludos.

Víctor Cuervo

Pedro

Como puedo hacer para que pueda digitarle numero ami vector desde el teclado en javascript me pueden ayudar?y luego me los imprima en pantalla

Víctor Cuervo

Joaquin

Quiero decir que muchos de los ejemplos que hay sobre Java en ésta página, son lo que estoy viendo en clase este año,  y agradezco tener estos ejemplos, seguramente que los aportes están hechos con mucho esfuerzo, pero quiero recalcar que para una persona como yo, que lleva unos meses intentando sacar adelante la asignatura de programación, en los ejemplos se hecha mucho en falta el «modo de ejecución» y ver el codigo completo, como ejemplo final, que en muchos ejemplos no aparece, entiendo que será por que quién pone el aporte da por sentado «muchas cosas», sobre lo que uno debe ya saber a estas altura de lo que está intentando realizar.

En fin, un saludo.

Víctor Cuervo

Víctor Cuervo

Buenas Joaquín,

Tienes toda la razón y estamos viendo cómo poder poner el modo de ejecución. En cuanto al tema del código fuente los tienes en cada página en el icono de la derecha que pone «Descargar Código Fuente». Además tienes todos los ejemplos Java en https://github.com/victorcuervo/lineadecodigo_java

Espero que te sirva de ayuda.

Saludos.

Víctor Cuervo

Paola Arzate

Me ayudo mucho el código para realizar mis tareas!!

Víctor Cuervo

cristina

hola! alguien me puede ayudar?
necesito un vector de 10 posiciones que me imprima cuales son los números parares,
y otro vector de 6 posiciones que me imprima solamente los números mayores.

Víctor Cuervo

Livh25

Hola Qusiera Saber si m pudieran ayudar a solucionar sta sucesion d numeros:
1,2,3,4,5,4,3,2,1,2,3,4,5,4,3,2,1,……¿cual es el numero que esta en la posicion 2011?

Víctor Cuervo

jairo martinez

Mejor tarde que nunca…
Algoritmo Serie_5_4_3_2_1_2_3_4_5_4_3_2_1__
j=1
i=1
Escribir «Ingrese el limite de la secuencia 1-2-3-4-5-4-3-2-1-2-3-4….»
Leer tope
Mientras i<=tope Hacer

Si j<5
Escribir "Pos:",i,"= ",j
j=j+1
i=i+1

Sino
k=i
Para j<-5 Hasta 2 Con Paso -1 Hacer

Escribir "Pos::",k,"= ",j
k=k+1
i=i+1
Fin Para

FinSi

// Escribir i
FinMientras

FinAlgoritmo

Víctor Cuervo

jairo martinez

se me olvido decir que es el numero 3

Víctor Cuervo

saenz

hola quisiera saber si pueden ayudarme a hacer un programa que muestre la
siguiente secuencia.

5 4 3 2 1 2 3 4 5
4 3 2 1 2 3 4
3 2 1 2 3
2 1 2
1

por fas me urge es mi tarea y no me sale, gracias..

Víctor Cuervo

david

hola me gustaría saber como hacer un programa como este pero si el numero mayor se repite varias veces quiero que me imprima cada una de las posiciones en que están. gracias

Víctor Cuervo

GREÑUDA

ME GUSTO ESTA PAGUINA ESTA BIEN PADRE PARA SOLUCIONAR MIS TAREA DE LA MATERIA DE JAVA

Víctor Cuervo

lineadecodigo

@Ron,

Pues no sé. He vuelto a ejecutar el código y lo que sale es que el mayor es el 15 y está en la posición 7.

Has probado a ejecutar el código que está en el enlace de Descargar ejemplo.

Víctor Cuervo

lineadecodigo

@Fhernd,

Un libro muy bueno. Básico para empezar a programar con Java.

Víctor Cuervo

Ron

ta malo el codigo me dice ke el valor 8 de la posicion 11 es el mayor!
xD

Víctor Cuervo

Fhernd

Hola!

Me ha gustado cómo ha logrado ordenar el código de este ejemplo con arreglos. Precisamente, en el libro de Deitel & Deitel, Cómo Programar Java Séptima Edición, sobre el capítulo 7mo, se cubre con mayor profundidad el tema de los Arreglos.

Hasta pronto y gracias por la información!

¿Algo que nos quieras comentar?

Déjanos tu comentario, no te preocupes que tu email no será publicado

*

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.