Número mayor y su posición

03/Mar/2009 Java , , , , 10 Comentarios

Este es un problema básico a la hora de trabajar con arrays en Java. La idea es buscar el número más grande del array y la posición que ocupa.

Lo primero es declarar el array de números e inicializarlo con una secuencia cualquiera:

  1. int[] listaNumeros = {1,4,7,8,9,2,7,15,4,6,9,8};

Lo siguiente, declarar dos variables, en las que almacenaremos el número mayor y su posición.

Para empezar asumiremos que el número mayor es el primero y que consecuentemente su posición es la cero (recuerda que los arrays empiezan por la posición 0).

  1. int iNumeroMayor, iPosicion;
  2.  
  3. //Presuponemos que el numero mayor es el primero
  4. iNumeroMayor = listaNumeros[0];
  5. iPosicion = 0;

Ahora, recorreremos todo el array. Para ello nos valemos de una estructura repetitiva tipo for y de la propiedad .length del array, la cual nos da el número de elementos que almacena el array.

  1. for (int x=1;x<listaNumeros.length;x++){...}

Por cada elemento del array que recorramos deberemos de preguntar si dicho elemento es mayor que el que tenemos almacenado. Si esto se cumple pondremos este como nuevo número mayor y la variable de iteración del bucle como posición.

  1. if (listaNumeros[x]>iNumeroMayor){
  2. iNumeroMayor = listaNumeros[x];
  3. iPosicion = x;
  4. }

Solo nos quedará mostrar los valores de iNumeroMayor e iPosicion. Simple, sencillo y en pocas líneas.

Vídeos sobre Java


Difunde el Conocimiento

Si te ha gustado el artículo o te ha sido de utilidad, no dejes de compartirlo con tus amigos en las redes sociales... Te estaremos muy agradecidos. :-D

10 comentarios en “Número mayor y su posición”

Víctor Cuervo

Livh25

Hola Qusiera Saber si m pudieran ayudar a solucionar sta sucesion d numeros:
1,2,3,4,5,4,3,2,1,2,3,4,5,4,3,2,1,……¿cual es el numero que esta en la posicion 2011?

Víctor Cuervo

jairo martinez

Mejor tarde que nunca…
Algoritmo Serie_5_4_3_2_1_2_3_4_5_4_3_2_1__
j=1
i=1
Escribir “Ingrese el limite de la secuencia 1-2-3-4-5-4-3-2-1-2-3-4….”
Leer tope
Mientras i<=tope Hacer

Si j<5
Escribir "Pos:",i,"= ",j
j=j+1
i=i+1

Sino
k=i
Para j<-5 Hasta 2 Con Paso -1 Hacer

Escribir "Pos::",k,"= ",j
k=k+1
i=i+1
Fin Para

FinSi

// Escribir i
FinMientras

FinAlgoritmo

Víctor Cuervo

jairo martinez

se me olvido decir que es el numero 3

Víctor Cuervo

saenz

hola quisiera saber si pueden ayudarme a hacer un programa que muestre la
siguiente secuencia.

5 4 3 2 1 2 3 4 5
4 3 2 1 2 3 4
3 2 1 2 3
2 1 2
1

por fas me urge es mi tarea y no me sale, gracias..

Víctor Cuervo

david

hola me gustaría saber como hacer un programa como este pero si el numero mayor se repite varias veces quiero que me imprima cada una de las posiciones en que están. gracias

Víctor Cuervo

GREÑUDA

ME GUSTO ESTA PAGUINA ESTA BIEN PADRE PARA SOLUCIONAR MIS TAREA DE LA MATERIA DE JAVA

Víctor Cuervo

lineadecodigo

@Ron,

Pues no sé. He vuelto a ejecutar el código y lo que sale es que el mayor es el 15 y está en la posición 7.

Has probado a ejecutar el código que está en el enlace de Descargar ejemplo.

Víctor Cuervo

lineadecodigo

@Fhernd,

Un libro muy bueno. Básico para empezar a programar con Java.

Víctor Cuervo

Ron

ta malo el codigo me dice ke el valor 8 de la posicion 11 es el mayor!
xD

Víctor Cuervo

Fhernd

Hola!

Me ha gustado cómo ha logrado ordenar el código de este ejemplo con arreglos. Precisamente, en el libro de Deitel & Deitel, Cómo Programar Java Séptima Edición, sobre el capítulo 7mo, se cubre con mayor profundidad el tema de los Arreglos.

Hasta pronto y gracias por la información!

¿Algo que nos quieras comentar?

Déjanos tu comentario, no te preocupes que tu email no será publicado

*

*